Dots - PayPal and Venmo Delayed – Incident details

PayPal and Venmo Delayed

Resolved
Degraded performance
Started about 2 years agoLasted about 15 hours

Affected

Venmo

Degraded performance from 12:38 AM to 3:30 PM

PayPal

Degraded performance from 12:38 AM to 3:30 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    PayPal and Venmo Payouts are delayed by 24-48 hours.